How to install wine on Ubuntu 16.04 64 bits

If you try to install wine, maybe you will see the following error:

The following packages have unmet dependencies:
 wine1.6 : Depends: wine1.6-i386 (= 1:1.6.2-0ubuntu14)
           Recommends: fonts-droid but it is not installable
E: Unable to correct problems, you have held broken packages.

I tried installing these fonts but without solution.
To avoid it, you can download the source code and compile it:

wget https://dl.winehq.org/wine/source/2.0/wine-2.0.tar.bz2
tar xjvf wine-2.0.tar.bz2
cd wine2.0
./configure

checking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.

This happend because you must be explicit if you want to install on a 64-bits platform.

./configure --enable-win64
make -j8
sudo make install

Enjoy it!

Comments

Post a Comment

Popular posts from this blog

Fix "Set scan parameters failed: Input/output error" on Ubuntu 16.04

from: can't read /var/mail/ in Python scripts

SNMP + Telegraf + InfluxDB